Amazon SES not listed

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #59005
    Andrew Hall
    Participant

    Thank you for creating this extension, however on the All Settings page, Amazon SES is not listed.
    I’ve put in a trace and found that do_action( 'postsmtp_register_transport', $postman_transport_registry ); in the main plugin is being called before add_action( 'postsmtp_register_transport', array( $this, 'register_transport' ) ); in the extension. Which might explain it?

    #60055
    Tim
    Moderator

    Hi Andrew,

    I am not the developer, however I am assisting with support. When you say that the API doesn’t appear in the All Settings page – do you mean that it is not showing in the dropdown as an option, or something else?

    Any screenshots would also be great. đŸ™‚

    Sorry for the delay in getting back to you!

    Kind Regards,
    Tim

    #60134
    Andrew Hall
    Participant

    Tim,

    Thanks for getting back to me. I tried to make a screenshot but the list disappears when you move away from the browser. I’m on the Show All Settings Page. I would expect SES to appear in the pull down against Type? The following are shown in the HTML source:

    <option class="input_tx_type_default" value="default" >Default</option><option class="input_tx_type_smtp" value="smtp" selected="selected">SMTP</option><option class="input_tx_type_gmail_api" value="gmail_api" >Gmail API</option><option class="input_tx_type_mandrill_api" value="mandrill_api" >Mandrill API</option><option class="input_tx_type_sendgrid_api" value="sendgrid_api" >SendGrid API</option><option class="input_tx_type_mailgun_api" value="mailgun_api" >Mailgun API</option>

    I have the latest version (just updated to 2.0.21) of Post SMTP and version 1.0.0 of the SES extension.

    Andrew.

    #60157
    Tim
    Moderator

    Hi Andrew,

    Okay, great! I am guessing you are seeing the same as my screenshot below? I just tested this up in a sandbox environment and get the same. I will ask Yehuda to check this out.
    Screenshot

    Kind Regards,
    Tim

    #60163
    Andrew Hall
    Participant

    Yes – that’s the problem. And the reason is as indicated in the initial post.

    Regards,
    Andrew

    #60165
    Tim
    Moderator

    Thank you! I’ll pass that on.

    Kind Regards,
    Tim

    #61049
    Kevin Shenk
    Participant

    Same deal here. Any workaround?

    #64348
    Paraic O Conghaile
    Participant

    Hi there,

    I found that was the case with me too. Doesn’t appear in the dropdown, but was able to enter the details in the settings form.

    Under Type, choose SMTP.
    Under Outgoing Mail Server Hostname, add your AWS mail server address
    Under Security, choose STARTTLS
    Under Authentication, choose the plain option and add your AWS_ACCESS_KEY_ID to Username and AWS_SECRET_ACCESS_KEY to Password. Worked for me!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.