Critical Error

Viewing 15 posts - 1 through 15 (of 70 total)
  • Author
    Posts
  • #57546
    paddy pepino
    Participant

    I added the license from my downloads page, entered into Office 365 setup and received the following error upon launch:

    “There has been a critical error on this website. Please check your site admin email inbox for instructions.”

    And now my site has crashed.

    So I disabled post smtp plugin via file manager and site is back up.

    Re-enabled and site crashed again.

    From my error log:

    Stack trace:
    (sensitive info replaced with xxxxxxxxx)

    #0 /home/xxxxxx/jaggroupllc.com/wp-content/plugins/post-smtp/Postman/Postman.php(201): PostmanLicenseManager->init()
    #1 /home/xxxxxxxx/jaggroupllc.com/wp-includes/class-wp-hook.php(287): Postman->on_plugins_loaded(”)
    #2 /home/xxxxxxxxx/jaggroupllc.com/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #3 /home/xxxxxxxxxx/jaggroupllc.com/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #4 /home/xxxxxxxxxxx/jaggroupllc.com/wp-settings.php(420): do_action(‘plugins_loaded’)
    #5 /home/xxxxxxxxxx/jaggroupllc.com/wp-config.php(93): require_once(‘/home/clicdzkk/…’)
    #6 /home/xxxxxxxxx/jaggroupllc.com/wp-load.php(37): require_once(‘/home/clicdzkk/… in /home/xxxxxxxxxx/jaggroupllc.com/wp-content/plugins/post-smtp/Postman/Extensions/License/PostmanLicenseManager.php on line 64

    #57555
    Tim
    Moderator

    Hi Paddy,

    Thanks for the post. A few questions:

    • What PHP version are you using?
    • What Post SMTP version are you using?
    • What Office 365 API extension version are you using?

    Can you also paste your diagnostics log, you can mark the reply as private if you wish and it will only be visible to you, me, and Yehuda.

    Kind Regards,
    Tim

    #57569
    paddy pepino
    Participant

    PHP 7.4

    post SMTP 2.0.20

    Not sure where to find API extension version or the diagnostics log

    #57571
    Tim
    Moderator

    Hi Paddy,

    Thanks for that.

    The API extension will be listed in the version number on /wp-admin/plugins.php (the Plugins page).

    Your diagnostics log will be under Post SMTP > Post SMTP, the under the right hand ‘Troubleshooting‘ section, you should see a ‘Diagnostics Test’ link which will take you to the log to copy.

    Thanks! 🙂

    Kind Regards,
    Tim

    #57576
    paddy pepino
    Participant

    SMTP Extension Version is 1.2

    If I’m following you correctly…

    I don’t see an API per se

    The Post STMP and O-365 extension plugins are disabled via the file manager in cPanel – or the site crashes.

    So. I cannot access the logs.

    Can they be found on the server ?

    #57743
    Tim
    Moderator

    Hi Paddy,

    No – the plugins must be active to get the logs. I would be surprised if you could not activate Post SMTP at least, alone.

    Can you try disabling all other plugins and activating just Post SMTP – this can sometimes help if there is a plugin conflict.

    Kind Regards,
    Tim

    #57804
    paddy pepino
    Participant

    Good morning

    I will give it a go and get back to you

    #57808
    Tim
    Moderator

    Thank you, that’s great.

    Kind Regards,
    Tim

    #57810
    paddy pepino
    Participant
    This reply has been marked as private.
    #57839
    Ian McMichael
    Participant

    Tim,

    I have also worked with yehudah on this issue at wordpress.org. I’ve offered him further diagnostics, if needed.

    Thanks,

    Ian.

    #57863
    Tim
    Moderator

    Thanks Ian – we appreciate that.

    Please note that going forward, any support/reports about the extensions must come directly through these forums – we are not permitted to support them on WP.org.

    Thanks!

    Kind Regards,
    Tim

    #57834
    paddy pepino
    Participant
    This reply has been marked as private.
    #57879
    Tim
    Moderator

    Hi Paddy,

    Thanks for your logs and extra info that you sent in. Can I check with you that you’ve definitely set up your Office 365 API correctly? The error that you are getting suggests that your API might not have the appropriate permissions.

    Please check against this guide: https://postmansmtp.com/configure-office-365-integration/

    Let us know how you get on.

    Kind Regards,
    Tim

    #57909
    paddy pepino
    Participant

    Although I set up the app in Office Azure – I never got thru setup as the site crashed.

    I asked for the serial number in another forum and was directed to my download license.

    That is the serial key / string of characters I used for setup.

    I entered the license number and clicked to go to the next step.

    That is when the site crashed and I received the critical error message.

    #57930
    Tim
    Moderator

    Hi Paddy,

    That’s strange. Would you be able to share some login details with us as a private reply? Please feel free to create a temp user.

    Kind Regards,
    Tim

Viewing 15 posts - 1 through 15 (of 70 total)
  • You must be logged in to reply to this topic.