Post SMTP v1.8.8 – lockfile and raise the PHP version

Post SMTP v1.8.8 – lockfile and raise the PHP version

Update: This version is now 1.8.8 for a few reasons so ignore 1.8.6 reference.

Hi,

Latest version 1.8.5 almost gave me a heart attack.

Many users reported the error

Could not create lockfile /tmp/.postman.lock

By quick look, the conclusion is folder permissions, but as time passed and more users complain
I realize that something else is going on.

After a second look on the “diagnostic test” the old PHP version 5.4 caught my eye so I started checking the code I have updated in the previous release.

The official Google PHP SDK docs say that the required PHP version is 5.4, so we god here.
Many SDK’s and Google too use “Guzzle” as their HTTP library, so I check there recommendation and BOOM

Somebody didn’t update his docs…
For now, I truly believe this is the problem, I can only confirm this after a few users will update me.

if you getting any other error after updating your version, do this steps:

  • log in to your account and see if there aren’t any notifications
  • if you are using Gmail, log in the google console and check the “Gmail API” is enabled.

You must have PHP 5.6 as a minimum requirement, all over the world people already use PHP 7 and above. I will not detail the security aspect of using old PHP version and the vulnerabilities.

Contact your web hosting support and upgrade PHP immediately.

In this version, I have added a check for the minimum PHP version required.

Contact Form 7

Contact Form 7 is flexible out of the box and instead of return this on error

Post SMTP is now integrated to Contact Form 7 and returning the actual error message to the user.

Error example
Error example

Please if you have any issues just open a ticket here on our WordPress support forums.

Leave a Comment