Breaks Site

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #57410
    Post Man
    Participant

    Sorry, otherwise a great plugin, but something like that shouldn’t happen.

    Steps to reproduce:
    – Plugin installed
    – Plugin activated
    – Entering given s/n
    –> Error

    (x) Fatal error: Uncaught Error: Class name must be a valid object or a string
    in /var/www/html/…/wp-content/plugins/post-smtp/Postman/Extensions/License/PostmanLicenseManager.php on line 79

    Even deactivating the plugin (extension) on the command line does not work:
    wp plugin deactivate better-logger-post-smtp-extension
    –> error

    Notice: Undefined index: Class in /var/www/html/…/wp-content/plugins/post-smtp/Postman/Extensions/License/PostmanLicenseManager.php on line 54
    Fatal error: Uncaught Error: Class name must be a valid object or a string in /var/www/html/…/wp-content/plugins/post-smtp/Postman/Extensions/License/PostmanLicenseManager.php:64
    Stack trace:
    #0 /var/www/html/…/wp-content/plugins/post-smtp/Postman/Postman.php(201): PostmanLicenseManager->init()
    #1 /var/www/html/…/wp-includes/class-wp-hook.php(287): Postman->on_plugins_loaded(”)
    #2 /var/www/html/…/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #3 /var/www/html/…/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #4 /var/www/html/…/wp-settings.php(420): do_action(‘plugins_loaded’)
    #5 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1237): require(‘/var/www/html/p…’)
    #6 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1158): WP_CLI\Runner->load_wordpress()
    #7 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Bootstrap/LaunchRunner.php(23): WP_CLI\Runner->start()
    #8 phar:///usr/local/bin/wp/vendor/wp-cl in /var/www/html/pbs_tchr1/wp-content/plugins/post-smtp/Postman/Extensions/License/PostmanLicenseManager.php on line 64
    Error: There has been a critical error on this website.Learn more about debugging in WordPress. There has been a critical error on this website.

    #57422
    yehuda
    Keymaster

    Hi,

    What version do you use of the plugin and the extension?

    #57430
    Post Man
    Participant

    WP 5.6 / PHP 7.2
    – post-smpt 2.0.20
    – better-logger-post-smtp-extension 1.1

    #58642
    yehuda
    Keymaster

    So sorry for the delay, please remove the extension for now, and if you have auth issues just put the credentials again.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.