Home Forums Extensions Office 365 Casual emails sent via smtp:none:none://localhost:25

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
  • #60889
    Christos Rakovitiswebelous


    I can confirm there is an issue when using O365 API on Postman: 2.0.21

    Some mail messages messages are being delivered with session ‘smtp:none:none://localhost:25’.

    As a result, SPF records fail and not delivered properly.

    Some other emails (example test mails) are being delivered via 365 API correctly.

    I cannot identify when and under which conditions. I thought it was WooCommerce, but I did a test order and it worked correctly.

    Thank you,

    Mailer: postsmtp
    HostName: REMOVED
    cURL Version: 7.29.0
    OpenSSL Version: NSS/3.53.1
    OS: Linux REMOVED #1 SMP Mon Nov 9 08:11:18 EST 2020 x86_64
    PHP: Linux 7.4.15 en_US.UTF-8
    PHP Dependencies: iconv=Yes, spl_autoload=Yes, openssl=Yes, sockets=Yes, allow_url_fopen=Yes, mcrypt=No, zlib_encode=Yes
    WordPress: 5.6.1 el UTF-8
    WordPress Theme: Flatsome Child
    WordPress Plugins: Akeeba Backup Professional for WordPress, Agile Store Locator, Contact Form 7, Cookie Notice & Compliance for GDPR / CCPA, Yoast Duplicate Post, Google Tag Manager for WordPress, Envato Market, Events Manager, Facebook for WooCommerce, greeklish-permalinks, Imagify, Loco Translate, MC4WP: Mailchimp for WordPress, PDF Embedder, Office 365 for Post SMTP Extension, Post SMTP, Regenerate Thumbnails, WC Hide Shipping Methods, Product Feed PRO for WooCommerce, WooCommerce Advanced Bulk Edit, WooCommerce PayPal Checkout Gateway, WooCommerce, WooSidebars, Wordfence Security, Yoast SEO Premium, WP All Export Pro, WP All Import Pro, WP Rocket, WP Rollback, WP All Import – WooCommerce Add-On Pro, ReCaptcha v2 for Contact Form 7, Yoast SEO: WooCommerce, YITH WooCommerce Order Tracking Premium, YITH WooCommerce Wishlist
    WordPress wp_mail Owner: /REMOVED/httpdocs/wp-content/plugins/post-smtp/Postman/PostmanWpMailBinder.php
    WordPress wp_mail Filter(s): wp_staticize_emoji_for_email, PostsmtpMailer->get_mail_args
    WordPress wp_mail_from Filter(s): wordfence::fixWPMailFromAddress
    WordPress phpmailer_init Action(s): wpcf7_phpmailer_init
    Postman: 2.0.21
    Postman Sender Domain (Envelope|Message): kelefthos.gr | kelefthos.gr
    Postman Prevent Message Sender Override (Email|Name): Yes | Yes
    Postman Active Transport: Office365 API (https://amazonses.com:443)
    Postman Active Transport Status (Ready|Connected): Yes | Yes
    Postman Deliveries (Success|Fail): 3991 | 25

    Tim NevilleTim

    Hi webelous,

    I’ve also experienced this too. It only seems to happen to a very small and somewhat random subsection of WooCommerce emails – is that right? From what you’ve said, it sounds like the same problem – very difficult to track down as some work fine (like test mails) and some just fail completely.

    I have flagged this to the Post SMTP developer/creator, Yehuda, who will look as soon as he is able. He is super busy, so we appreciate your patience.

    If you do come across any more useful debugging information, please feel free to post it on this topic – as it may well be helpful in getting a bug fix for this.


    Kind Regards,

    Christos Rakovitiswebelous

    Hello Tim,


    It doesn’t seem related to WooCommerce.

    I’ve tried to do a password reset for a test account, and the plugin sent it via smtp:none:none.

    Unfortunately I don’t have any other info on how to reproduce this, seems casual.


    Scott HarrisScott Harris

    exact same issue:

    Test emails:
    are sent and received perfectly perfectly.

    All other Emails sent out from theme (Avada):
    Logged as sent – but never received – they have Delivery-URI: smtp:none:none://localhost:25

    When these email are resubmitted it spits out an this error:
    https://graph.microsoft.com/v1.0/me/sendMailresulted in a400 Bad Request` response: {“error”:{“code”:”InvalidInternetMessageHeader”,”message”:”The internet message header name ‘MIME-Version’ should start (truncated…)”



    I’m also facing this exact same issue. Emails sent via the test are received, but any other emails sent by plugins such as Gravity Forms are logged as “sent” but the transcript states “smtp:none:none://localhost:25” and no emails are received..

    Looking forward to resolving this!


    So after spending some time trying to figure this out, we have found a workaround, while the good people of Post SMTP are looking into a more permanent solution. This basically removes the auto generated email headers. Add this to your site’s functions.php and test, should work:

    //remove the automatically generated email headers
    function remove_auto_email_header( $args ) {
      $headers = array();
      foreach ( $args['headers'] as $header ) {
        if ( false === strstr( $header, 'Auto-Submitted' ) ) {
          $headers[] = $header;
      $args['headers'] = $headers;
      return $args;
    add_filter( 'wp_mail', 'remove_auto_email_header', 10, 1 );

    Spoke too soon. Looks like this code resolves the error below, but not delivery issues from a contact form

    https://graph.microsoft.com/v1.0/me/sendMailresulted in a400 Bad Request` response: {“error”:{“code”:”InvalidInternetMessageHeader”,”message”:”The internet message header name ‘MIME-Version’ should start (truncated…)

    David SmithDavid Smith

    HI there,

    I have an open support post (Email sent successfully but not being being received by emails using 365?), which appears to be narrowed down to this same issue..so seems to be widespread. Very frustrating.

    I use a portal plugin that sends a customer a welcome email when I assign them in WP (this works fine, as it uses the amazonsses:443). This email contains a password reset link, which WP sends out (standard WordPress function to reset password). However this email never arrives after they reset because it uses: smtp:none:none://localhost:25.

    This is very frustrating as the email never arrives and therefore the registration process fo ray customer can never complete.

    Please, can we address this issue – as it appears to be widespread and only for Office 365 emails, which is the majority of mail users.

    I hope this gets resolved very soon – in the meanwhile I am being forced to look around for a more reliable SMTP plugin/service.

    Joost SannenJoost Sannen

    Hi, I’m new to this plugin and love the fact it’s free as we are a small non-profit organisation.

    But I have to say all e-mails sent with WPForms have this smtp:none:none://localhost:25

    The e-mail is sent though but will mostly end up in the spam folder. I hope a solution is available very soon. I can troubleshoot for you if you want.

    Best regards, Joost

    Joost SannenJoost Sannen

    Forgot to mention we use the Office 365 extension.

    Dustin RohdyDustin Rohdy

    We are experiencing the same issue. I have also opened a support request.

    David SmithDavid Smith

    The smtp:none:none://localhost:25 is an issue for the Outlook 365 plugin, which unfortunately renders this unusable for me. I spend ages trying to resolve this on a DNS level, but it ended being the plugin. Appreciate it is a free plugin ( fully appreciate this) but I can’t wait until the fix is issued, which is a real shame.

    I have had to revert to using a paid plugin, which worked perfect. So if you want this working now, then search SMTP on WordPress plugins and its the most downloaded. They do a free version, but if you want Outlook (api) then this does work.

    Hope you guys here get the plugin error fixed for Outlook and good luck.

    Dustin RohdyDustin Rohdy

    I’ve reverted back to the 2.0.20 release for now, which is working fine.


    Same here. Test Emails work fine. All WooCommerce emails get a “Unable to send mail.” status and solution : “Not found, check status column for more info.”. In Session Transcript it says : “smtp:none:none://localhost:25”
    Any quick fix?


    I tested downgraded the plugin to 2.0.20 as suggested above.
    This indeed solves the smtp:none:none://localhost:25 problem but the following error remains:
    Client error:POST https://graph.microsoft.com/v1.0/me/sendMailresulted in a400 Bad Requestresponse: {"error":{"code":"ErrorParticipantDoesntHaveAnEmailAddress","message":"A participant without an email address is not all (truncated...)

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.
Scroll to Top